Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  1. Clone Lens:

    Code Block
    languagebash
    themeRDark
    git clone git@gitlab.bath.ac.uk:digital/lens.git


  2. Install Rudy Ruby Sass, globally

    Code Block
    languagebash
    themeRDark
    sudo gem install sass


    Note

    We are using Ruby Sass, which is no longer maintained by developers, as we have not yet upgraded to use Dart Sass


  3. Install the Grunt CLI, globally

    Code Block
    languagebash
    themeRDark
     npm install -g grunt-cli


  4. Change directory to Lens

    Code Block
    languagebash
    themeRDark
    cd lens


  5. Install Grunt and it's dependencies from the package.json

    Code Block
    languagebash
    themeRDark
    npm install # npm install --no-bin-links for Windows users (so that it doesn't try (and fail) to create symlinks)


...